Service Outage
Incident Report for
Insights
Resolved
This incident is resolved.
Posted
May
27
,
2026
-
20:39
CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
May
27
,
2026
-
20:25
CDT
Investigating
We are currently experiencing an outage. Our team is actively working to restore service.
We will provide updates every 30 minutes until the issue is resolved.
We apologize for the inconvenience and appreciate your patience.
Posted
May
27
,
2026
-
20:05
CDT
This incident affected: Insights (Insights platform, Survey, Notifications).
×
Subscribe to Incident
Subscribe to updates for
Service Outage
via . You'll receive .