Platform Performance
Incident Report for Insights
Resolved
This incident has been resolved - we will continue to monitor.
Posted Jun 14, 2023 - 10:20 CDT
Monitoring
We have identified the issue and put a fix in place. We will continue to monitor the health of the system.
Posted Jun 14, 2023 - 09:20 CDT
Investigating
We are currently investigating performance issues with the platform
Posted Jun 14, 2023 - 09:05 CDT
This incident affected: Insights (Insights platform).